Overdue Documents
Incident Report for Ocrolus
Postmortem

Bank statements go through a multi-step process that involves machine processing and human verification. Upon investigation of this incident, our engineers identified a race condition that prevented the first verification step from being marked as completed, which stopped the verification process for the affected documents.

Our engineering team has deployed a short-term fix for the race condition, and are currently working on a long-term solution to be deployed in the coming weeks.

Posted Jun 30, 2023 - 17:54 EDT

Resolved
All docs affected by this incident have completed verification, and their average time overdue was 3 hours and 2 minutes. We will investigate the root cause and post an update once it has been determined.
Posted Jun 21, 2023 - 21:04 EDT
Update
We've gone through 99% of the backlog and there are less than five overdue docs in process.
Posted Jun 21, 2023 - 20:46 EDT
Investigating
About 30% of the documents uploaded between 3pm and 4pm ET failed to get processed by our human-in-the-loop document processing system, and we are currently working through that backlog. We are still investigating the root cause. This incident did not cause any failures for the Ocrolus API or Dashboard.
Posted Jun 21, 2023 - 19:35 EDT
This incident affected: Document Processing.