The issue impacting the Import to Encompass modal has been resolved. Based on the update from ICE, Encompass Partner Connect is now fully operational.
All backlog orders are currently being processed, and new orders are processing immediately.
Note: Orders submitted through Encompass Partner Connect prior to 7:30 AM ET may need to be resubmitted.
Posted Jul 30, 2026 - 15:13 EDT
Monitoring
Update: Progress has been made from ICE end, in restoring the processing of Encompass Partner Connect orders. The backlog has started processing, and completed orders should begin appearing in the application. Please note that processing the entire backlog will take some time, so users may continue to experience delays until all queued orders have been processed. We will continue to monitor the situation and provide further updates as they become available.
Posted Jul 30, 2026 - 14:18 EDT
Update
Update from ICE:
Our teams continue to focus on restoring our EPC service. This is absolute critical priority for us. We are actively working through methods to restore this service & we appreciate your patience as we continue.
Posted Jul 30, 2026 - 13:31 EDT
Investigating
We are currently investigating an issue where the Import to Encompass modal is not loading.
Based on our initial analysis, the issue is related to an upstream ICE service as confirmed by ICE support. We will provide further updates as more information becomes available.