Overdue Documents
Incident Report for Ocrolus
Resolved
We again experienced performance issues with our human-in-the-loop verification system between approximately 10:30pm and 11:50pm ET, which resulted in 517 documents becoming overdue by an average of 48 minutes.
Posted Dec 04, 2023 - 23:50 EST
Update
We have processed the backlog of overdue documents and this incident is now resolved.
Posted Dec 04, 2023 - 19:08 EST
Monitoring
This incident was caused by a spike in bank statement uploads. Our human-in-the-loop verification system is fully operational and we are currently working through the backlog.
Posted Dec 04, 2023 - 17:03 EST
Investigating
Between approximately 3:35pm and 4:25pm ET, we experienced performance issues with our human-in-the-loop verification system that prevented verifiers from processing uploaded documents, which will lead to increased turnaround times and overdue documents for documents that require human verification. The Ocrolus API and Dashboard are not affected by this incident. We are still investigating the root cause.
Posted Dec 04, 2023 - 16:37 EST
This incident affected: Human-in-the-loop Verification System.