Analytics API Outage

Incident Report for Ocrolus

Resolved

Webhook notifications for the book.analytics_v2.generated event have been sent for all the affected books.
Posted Nov 20, 2023 - 16:58 EST

Identified

The deployment rollback was successful. We are now reprocessing the backlog for enriching transactions and the relevant webhook notifications will be sent for the affected books shortly.
Posted Nov 20, 2023 - 15:34 EST

Investigating

A software deployment that took place at 1:08pm ET has resulted in an outage that's affecting some of our API endpoints for analytics. We are in the process of rolling back that deployment.
Posted Nov 20, 2023 - 15:04 EST
This incident affected: Ocrolus API.