Delays with Encompass interactions causing degraded performance

Incident Report for Ocrolus

Resolved

The system has fully recovered, and encompass interactions are now functioning as expected.
Posted Sep 03, 2025 - 13:17 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2025 - 12:52 EDT

Identified

We identified the root cause and have applied the necessary fix. Services are stabilizing and we continue to monitor performance.
Posted Sep 03, 2025 - 12:47 EDT

Investigating

We are noticing delays with Encompass interactions, causing degraded performance. We are actively looking into this.
Posted Sep 03, 2025 - 12:38 EDT
This incident affected: Dashboard and Income.