Detect Degraded Performance

Incident Report for Ocrolus

Resolved

The system has fully recovered, and all Detect services are now running smoothly.
Posted Oct 14, 2025 - 17:11 EDT

Monitoring

We are currently processing the backlog of messages and are approximately one hour behind. This delay is limited in scope — only a subset of books are affected, while the majority are processing as expected. Our teams continue to monitor the situation closely to ensure full recovery and system stability.
Posted Oct 14, 2025 - 16:01 EDT

Identified

We identified the root cause and have applied the necessary fix.
Posted Oct 14, 2025 - 14:38 EDT

Update

We are continuing to investigate this issue.
Posted Oct 14, 2025 - 14:08 EDT

Investigating

We are currently experiencing a delay in our Detect, and you may notice an increase in turnaround time (TAT). Our team is actively investigating the issue, and we’ll keep you updated as we make progress.
Posted Oct 14, 2025 - 13:24 EDT
This incident affected: Detect.