Delay in Document Processing Services

Incident Report for Ocrolus

Resolved

System recovery began at 19:52 EDT and the backlog was successfully cleared by 22:02 EDT. Services have returned to normal operation.
Posted May 14, 2025 - 22:06 EDT

Monitoring

The system is currently coming back online, and our team is actively working to process the backlog and restore normal operations as quickly as possible.
Posted May 14, 2025 - 19:52 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 18:53 EDT

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 17:52 EDT

Investigating

We are currently experiencing a delay in our document processing services. As a result, you may notice an increase in turnaround time (TAT). Our team is actively investigating the issue, and we’ll keep you updated as we make progress.
Posted May 14, 2025 - 17:52 EDT
This incident affected: Document Processing.