Email Notifications Outage
Incident Report for Ocrolus
Postmortem

Our email notifications rely on a distributed event streaming system and an email events consumer. This incident was caused by a a failure of that system and a software bug that prevented the event consumer from restarting. We have deployed a fix for the software bug and are adding additional monitoring for our event streaming system.

Posted Dec 14, 2023 - 12:37 EST

Resolved
Our email notification system failed to deliver BOOK_VERIFIED events and password reset emails from approximately 3:30pm ET on December 12th to 11:30 AM ET on December 13th. We are still investigating the root cause of this issue.
Posted Dec 12, 2023 - 15:30 EST