Overdue Documents
Incident Report for Ocrolus
Resolved
Due to a software deployment, documents uploaded between 10:30am and 1:30pm ET experienced increased turnaround times. Our verifiers have worked through the backlog, and turnaround times have returned to normal. Our human-in-the-loop verification system is fully functional.
Posted Feb 22, 2024 - 14:01 EST
Investigating
We are currently investigating an issue related to increased turnaround times.
Posted Feb 22, 2024 - 13:32 EST
This incident affected: Human-in-the-loop Verification System.