Delays in Document Processing and Detect Completion

Incident Report for Ocrolus

Resolved

The system has fully recovered, and all Detect and Document Processing services are now running smoothly.
Posted Apr 23, 2026 - 01:08 EDT

Update

We have identified the issue impacting the Detect service and are actively monitoring the implemented fix. Our team is working to fully restore normal performance and is currently assessing the timeline for complete recovery.

The issue affecting Document Processing has been resolved, and all related backlogs have been successfully cleared.
Posted Apr 22, 2026 - 21:45 EDT

Monitoring

We are continuing to clear the backlog and are actively monitoring the situation.
Posted Apr 22, 2026 - 19:47 EDT

Investigating

Some customers are currently experiencing delays in document processing and Detect services, which may result in increased turnaround times (TAT) and slower Detect completion for documents. Our team is actively working through the backlog and monitoring the situation closely. We will continue to provide updates as progress is made.
Posted Apr 22, 2026 - 18:59 EDT
This incident affected: Document Processing and Detect.