Document Processing Degradation – Unknown Rejections

Incident Report for Ocrolus

Resolved

We continued to monitor the system after the reprocessing to make sure everything was working as expected.
The system has now fully recovered, and all Document Processing services are running normally.
Posted Jul 07, 2026 - 00:09 EDT

Update

Root cause has been fixed and we are currently reprocessing the impacted documents. Our teams are closely monitoring the situation to ensure a complete recovery and maintain system stability throughout the process.
Posted Jul 06, 2026 - 15:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2026 - 12:00 EDT

Identified

Our team has identified the cause of the issue resulting in unknown document rejections and is actively working on a fix.
Posted Jul 06, 2026 - 11:53 EDT

Update

We are continuing to investigate this issue.
Posted Jul 06, 2026 - 11:29 EDT

Investigating

We are currently investigating an issue causing an increased number of document processing failures due to unknown rejections. As a result, some documents may be rejected unexpectedly during processing.

Our engineering team is actively working to identify the root cause and restore normal processing. We will provide additional updates as more information becomes available.
Posted Jul 06, 2026 - 11:29 EDT
This incident affected: Document Processing.