Document Processing Delays

Incident Report for Ocrolus

Resolved

Our document processing system has fully returned to normal operations. Some documents may still experience delays as we work through the remaining backlog.
Posted Oct 10, 2025 - 13:52 EDT

Monitoring

We have restored system operation, and we are working through the backlog of documents.
Posted Oct 10, 2025 - 12:37 EDT

Investigating

We are currently experiencing a delay in our document processing services. As a result, you may notice an increase in turnaround time (TAT). Our team is actively investigating the issue, and we’ll keep you updated as we make progress.
Posted Oct 10, 2025 - 11:36 EDT
This incident affected: Document Processing.