Document Processing Delays
Incident Report for Ocrolus
Resolved
Our document verification system has fully recovered and we have returned to normal operations.
Posted Jun 28, 2024 - 13:06 EDT
Monitoring
Our document processing system is now recovering after a bug fix for this issue was released.

We are continuing to monitor the situation.
Posted Jun 28, 2024 - 12:21 EDT
Identified
We have identified an issue with our task queueing system that is causing document processing to be delayed.

We are currently investigating and will share more information as it becomes available.
Posted Jun 28, 2024 - 11:59 EDT
This incident affected: Document Processing.