Delays in Document Processing Services

Incident Report for Ocrolus

Resolved

The backlog has returned to normal levels, and turnaround time (TAT) has been steadily improving. We continue to actively monitor TAT and overall system health.
Posted Aug 11, 2026 - 08:53 EDT

Monitoring

We have identified the root cause of the issue and successfully implemented a fix. Document processing has returned to normal, and we are actively working to clear the backlog accumulated during the incident.

While the backlog is being processed, customers may continue to experience elevated turnaround times (TAT). Our team is closely monitoring the recovery and prioritizing backlog clearance to restore normal TAT as quickly as possible.
Posted Aug 11, 2026 - 02:13 EDT

Update

The issue causing delays in Document Verification is still ongoing. Our team continues to actively investigate the issue and is working on a fix with highest priority.

We will continue to monitor the situation closely and provide further updates as more information becomes available.
Posted Aug 11, 2026 - 00:20 EDT

Investigating

We are currently experiencing delays in Document Verification due to degraded performance affecting our document processing system.

Our team is actively investigating the issue and working to restore normal processing times. We will provide further updates as more information becomes available.
Posted Aug 10, 2026 - 21:16 EDT
This incident affected: Document Processing.