Higher-than-expected document volume
Incident Report for Ocrolus
Resolved
Between 01:00 PM and 05:00 PM ET on November 25th, we experienced an unexpected surge in document uploads from various clients, which led to delays in processing. However, our team worked diligently to address the issue and successfully processed all the documents by 11:00 PM ET.
Posted Nov 26, 2024 - 05:43 EST
Update
We are actively continuing to process the documents and are prioritising clearing the backlog as quickly as possible.
Posted Nov 25, 2024 - 19:22 EST
Investigating
We are currently experiencing delays in document processing due to an unexpected surge in volume from multiple clients. Our team is actively working to process these documents as quickly as possible. However, some delays are anticipated during this time.
Posted Nov 25, 2024 - 17:27 EST
This incident affected: Document Processing.