Encompass Connector Service Failure

Incident Report for Ocrolus

Resolved

The issue was resolved by correcting the deployment configuration and restarting the affected services.
Posted May 09, 2025 - 17:30 EDT

Identified

Between 3:55 and 4:40 PM EST, a faulty deployment caused the Ocrolus Encompass Connector Service to fail, which in turn halted all classification-related workflows. The root cause was a combination of Liquibase checksum mismatches, preventing the services from initializing properly from the deployment. As a result, no classification jobs were processed during this window, leading to delays, a queue backlog, and potential SLA impacts for downstream mortgage-related workflows include income analytics. The issue was resolved by correcting the configuration and restarting the affected services and we're restarting classification jobs.
Posted May 09, 2025 - 16:50 EDT
This incident affected: Income.