Overdue Documents
Incident Report for Ocrolus
Resolved
We have completed processing the backlog. We will continue our investigation of the incident and will provide a postmortem in the next few business days.
Posted Dec 28, 2023 - 18:41 EST
Monitoring
We are about 3/4 of the way through the backlog.
Posted Dec 28, 2023 - 16:11 EST
Identified
This incident was caused by a queuing system failure that occurred around 10:50am ET. Our human-in-the-loop verification system is now fully operational and we are currently working through the backlog.
Posted Dec 28, 2023 - 13:40 EST
Investigating
We are currently experiencing intermittent outages with our human-in-the-loop verification system that will result in longer turnaround times for documents that require human verification. We are still investigating the root cause. The Ocrolus API and Dashboard are not affected by this incident.
Posted Dec 28, 2023 - 12:29 EST
This incident affected: Human-in-the-loop Verification System.