Delays in Document Processing Services

Incident Report for Ocrolus

Resolved

The backlog has returned to normal levels, and turnaround time (TAT) has been steadily improving. We continue to actively monitor TAT and overall system health.
Posted Mar 17, 2026 - 17:17 EDT

Monitoring

We are continuing to clear the backlog and are actively monitoring the situation.
Posted Mar 17, 2026 - 15:44 EDT

Investigating

Some customers are experiencing a delay in our document processing services. As a result, you may notice an increase in turnaround time (TAT). Our team is actively working through our backlogs, and we’ll keep you updated as we make progress.
Posted Mar 17, 2026 - 13:30 EDT
This incident affected: Document Processing.